Kom ihåg mig?

City Network och mod_rewrite? Någon nattsuddare som vet?

 
Ämnesverktyg Visningsalternativ
Gammal 2010-12-30, 23:35 #1
clirres avatar
clirre clirre är inte uppkopplad
Har WN som tidsfördriv
 
Reg.datum: Nov 2005
Inlägg: 1 005
clirre clirre är inte uppkopplad
Har WN som tidsfördriv
clirres avatar
 
Reg.datum: Nov 2005
Inlägg: 1 005
Standard City Network och mod_rewrite? Någon nattsuddare som vet?

Hej,

Jag har testat i en timme och googlat i en timme men kan för mitt liv inte förstå varför mitt htaccess-script som fungerat utmärkt hos Binero inte fungerar på City Network.

Det är egentligen inte ens fel på scriptet för jag har kört ett "hello world"-simpelt script som inte heller fungerade:

RewriteEngine on
RewriteRule ^alice.html$ bob.html

Som bara orsakar 404r. Jag har kollat phpinfo() och Ctrl+F:at efter "mod_rewrite" utan resultat.

Betyder allt detta att City Network inte har möjlighet till mod_rewrite? Eller måste man lägga till nåt i koden för att få det att fungera.

Jag har förstås inte tålamod till att vänta till morgonen med att få min ticket besvarad. Ville ju jobba med sidan nu!

Så, ett snabbt svar uppskattas.
clirre är inte uppkopplad   Svara med citatSvara med citat
Gammal 2010-12-31, 01:01 #2
fluortant fluortant är inte uppkopplad
Nykomling
 
Reg.datum: Nov 2010
Inlägg: 33
fluortant fluortant är inte uppkopplad
Nykomling
 
Reg.datum: Nov 2010
Inlägg: 33
Testa:
Options -MultiViews
RewriteEngine On
RewriteBase /

RewriteRule ^alice.html$ bob.html
fluortant är inte uppkopplad   Svara med citatSvara med citat
Gammal 2010-12-31, 01:34 #3
ChLa ChLa är inte uppkopplad
Medlem
 
Reg.datum: Aug 2006
Inlägg: 152
ChLa ChLa är inte uppkopplad
Medlem
 
Reg.datum: Aug 2006
Inlägg: 152
Jodå, CN stödjer mod_rewrite på mitt konto iaf : ) (nya)
Kod:
RewriteEngine on
RewriteRule ^alice.html$ bob.html
ger 404 för mig också, medan fluortants kod fungerar.
__________________
...

Senast redigerad av ChLa den 2010-12-31 klockan 01:40
ChLa är inte uppkopplad   Svara med citatSvara med citat
Gammal 2010-12-31, 08:26 #4
clirres avatar
clirre clirre är inte uppkopplad
Har WN som tidsfördriv
 
Reg.datum: Nov 2005
Inlägg: 1 005
clirre clirre är inte uppkopplad
Har WN som tidsfördriv
clirres avatar
 
Reg.datum: Nov 2005
Inlägg: 1 005
Ah, lovely! Det var

Options -MultiViews

RewriteBase /

som gjorde tricket. Varför detta behövdes har jag ingen aning om, men nu fungerar det och sidan är uppe igen, tack!
clirre är inte uppkopplad   Svara med citatSvara med citat
Svara


Aktiva användare som för närvarande tittar på det här ämnet: 1 (0 medlemmar och 1 gäster)
 
Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av

Forumhopp


Alla tider är GMT +2. Klockan är nu 19:51.

Programvara från: vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
 
Copyright © 2017