Kom ihåg mig?

mod_rewrite i .htaccess

Ämnesverktyg Visningsalternativ
Oläst 2011-07-24, 18:22 #1
Kimppas avatar
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
 
Reg.datum: Jul 2010
Inlägg: 788
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
Kimppas avatar
 
Reg.datum: Jul 2010
Inlägg: 788
Standard mod_rewrite i .htaccess

Hej alla,

Sitter och försöker få ordning på världens mest komplicerade (enligt mig)
problem gällande .htaccess och mod_rewrite.

Försöker få en URL att bli från www.sida.se/site.php?id=1 till www.sida.se/1
men får verkligen inte till det och nu fungerar inte vanliga PHP variabel-vägen
heller. Har strulat till det ordentligt.

Använder mig utav koden:
Citat:
RewriteRule ^([^/]*)$ /land.php?id=$1 [L]
Är det någon som ser vad det är jag gör för fel?


EDIT:

Har även gått igenom alla andra trådar på forumet om detta men får ingen
av de koderna att fungera heller. Wordpress har inga problem att skriva om
.htaccess filen på servern och jag har även testat en enkel redirect som fungerar
men får inte till det där med variablerna...

Senast redigerad av Kimppa den 2011-07-24 klockan 18:59
Kimppa är inte uppkopplad   Svara med citatSvara med citat
Oläst 2011-07-24, 22:50 #2
fluortant fluortant är inte uppkopplad
Nykomling
 
Reg.datum: Nov 2010
Inlägg: 33
fluortant fluortant är inte uppkopplad
Nykomling
 
Reg.datum: Nov 2010
Inlägg: 33
Testa:
Kod:
Options -MultiViews
RewriteEngine On
RewriteBase /

RewriteRule ^land/([0-9]+) land.php?id=$1 [QSA]
fluortant är inte uppkopplad   Svara med citatSvara med citat
Oläst 2011-07-25, 14:12 #3
Kimppas avatar
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
 
Reg.datum: Jul 2010
Inlägg: 788
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
Kimppas avatar
 
Reg.datum: Jul 2010
Inlägg: 788
Tack! Testar den så fort man kommer hem
Kimppa är inte uppkopplad   Svara med citatSvara med citat
Oläst 2011-07-25, 17:19 #4
Kimppas avatar
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
 
Reg.datum: Jul 2010
Inlägg: 788
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
Kimppas avatar
 
Reg.datum: Jul 2010
Inlägg: 788
fluortant, koden fungerade! Men nu blir adressen URL.se/land/1 istället för URL.se/1. Går det att få den att bara bli URL.se/1 eller är det jag som bara tror det?

Tack för hjälpen!
Kimppa är inte uppkopplad   Svara med citatSvara med citat
Oläst 2011-07-25, 18:26 #5
Kimppas avatar
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
 
Reg.datum: Jul 2010
Inlägg: 788
Kimppa Kimppa är inte uppkopplad
Mycket flitig postare
Kimppas avatar
 
Reg.datum: Jul 2010
Inlägg: 788
Fick till det med denna kod (om någon annan har samma problem):

Citat:
Options -MultiViews
RewriteEngine On
RewriteBase /

RewriteRule ^([A-Za-z0-9-]+)/?$ land.php?id=$1 [L]
Kimppa är inte uppkopplad   Svara med citatSvara med citat
Svara


Aktiva användare som för närvarande tittar på det här ämnet: 1 (0 medlemmar och 1 gäster)
 
Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av

Forumhopp


Alla tider är GMT +2. Klockan är nu 12:53.

Programvara från: vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
 
Copyright © 2017